ArmA2: Operation Arrowhead für 22,41€ inkl. Versand vorbestellen! …ein Teil des Geldes geht an uns und hilft dabei A-A.de im Netz zu halten.
04.06.08

ArmA RealTimeEditor v4 Revision 2

Neue Version des RealTimeEditor von i0n0s im BI-Forum released. Gleichzeitig ist für diejenigen von Euch die ECS nutzen ein Fix dabei, da sich ECS mit RTE wohl nicht ganz verträgt.


14 Kommentare:


04.06.08 um 23:45 Uhr

Al Simmons

Avatar
Registriert: 08.06.2006
Kommentare: 67

Zitieren eMail
Nice! Gibts auch nen Changelog?
05.06.08 um 01:10 Uhr

KaKu Redakteur

Avatar
Registriert: 27.11.2006
Kommentare: 91

Zitieren eMail
...ups, sorry ^^

Changes to previous version:


* Re added ability to place units.
* Added ability to place groups
* Objects can get selected by single click
* Reworked GUI
* Reworked export
* Added debug console
05.06.08 um 03:38 Uhr

Big Fan

Gast


Zitieren
Schön. Ist denn das jetzt geregelt das man die einheiten die man setzt auch dann im normalen editor da sind oder wird nach wie vor alles gelöscht was mit dem RTE erstellt hat? Hatte nur mal einer der ersten versionen ausprobiert und musste feststellen das ja alles gelöscht wird wenn ich wieder in den normalen editor gehe. Das hat mich extremst angekotzt so das ich auf das dingens kein bock mehr hatte :D
05.06.08 um 07:42 Uhr

S.A.Jacker


Registriert: 11.10.2006
Kommentare: 6

Zitieren eMail
Habs angetestet und muss sagen das es das setzen von Einheiten enorm vereinfachen würde.Super Sache das ist.
Bloss,wie bekommt man die Scripte oder Templates an die Arbeit????
Wenn ich die Skripte im normalen Editor aktiviere bekomme ich eine Fehlermeldung.
Grübel.........
05.06.08 um 11:45 Uhr

i0n0s

Gast


Zitieren
@S.A. Jacker:
Was für ein Fehler kommt denn?
Schick es einfach mal an die im Manuel angegebene Mail-Addy. Dann kann ich es mir anschauen.

@Big Fan:
Das ist aus technischen Gründen nicht möglich. Daher immer exportieren was in Rev 2 mit 2 Klicks (Select All, Export) endlich einfach gelöst wurde ;)
05.06.08 um 16:57 Uhr

Al Simmons

Avatar
Registriert: 08.06.2006
Kommentare: 67

Zitieren eMail
@i0n0s:
Gute Arbeit, habe zwar noch keine Gelegenheit gehabt die aktuelle Version zu testen jedoch ist die vorherige bereits seit ner Weile bei mir Standard zur Unterstützung beim Missi Editing.
Wäre es Möglich die Option zum Kippen von Objekten einzubauen?
Gruß Al
05.06.08 um 16:57 Uhr

ST6_Predator


Registriert: 20.09.2006
Kommentare: 97

Zitieren eMail
Kann zwar Einheite genau platzieren aber bein testen fehlt die KI
i
05.06.08 um 17:52 Uhr

i0n0s

Gast


Zitieren
@Al Simmons:
In einer Spielwiese habe ich die Möglichkeit Objekte per SetVectorUp zu kippen. Dies braucht aber noch viel Arbeit bis es veröffentlicht werden kann.

@(ST6)Predator:
Was meinst du mit "fehlt die KI"?
05.06.08 um 20:31 Uhr

Al Simmons

Avatar
Registriert: 08.06.2006
Kommentare: 67

Zitieren eMail
Zitat von (ST6)Predator:
Kann zwar Einheite genau platzieren aber bein testen fehlt die KI
i
Ja das hab ich auch festgestellt. Einheiten lassen sich zwar platzieren, reagieren auch auf die Umwelt allerdings greifen sie nicht an.
05.06.08 um 21:45 Uhr

i0n0s

Gast


Zitieren
@KI:
Habe es gerade auch nochmal angeschaut und mir das Biki zu Gemüte getan:
createCenter reicht nicht, ich müsste diese noch verfeinden.
Als aktuelle Lösung kann ich aktuell nur anbieten, dass ihr von jeder Seite eine Einheit so platziert oder die Seiten manuell verfeindet.

Danke für eurere Fehlermeldung!
Ein weiterer Bug wird ausgemerzt.
05.06.08 um 21:52 Uhr

ST6_Predator


Registriert: 20.09.2006
Kommentare: 97

Zitieren eMail
Gibts dafür schon ne Lösung ?
06.06.08 um 01:38 Uhr

S.A.Jacker


Registriert: 11.10.2006
Kommentare: 6

Zitieren eMail
@i0n0s:
sorry for delay,aber die Arbeit......
Hmmm,schade ,man kann keine Bilder einfügen.
Na dann mal die Finger angespitzt.
Also,mit dem Editor arbeiten klappt schon ganz gut.Die Einheiten markieren,RTE Capture auf aktives monitoring schalten,im Spiel im Editor auf exportieren,dann zurück zum RTE Capture und auf convert to script.
Was ich dann gemacht habe ist,das Script RTE_export.sqf in den Mission Ordner kopiert und im Spiel per Auslöser das Script aktiviert.Dann kommt Fehlermeldung:
_driver [#] setrank _rank ;
error setrank typ nichts,erwartet object
} else [
_name = "";
};
_unit = [#]createvehicle [_mode],_pos,[],0,_spe...`
Das war der Versuch mit leerem M113.
Hab es eben mal mit einem besetzten Truck versucht.RTE Capture hat die Daten aufgenommen.Hab dann Capture to script gedrückt.Script macht er aber nicht,stattdessen steht unten im Debuglog:
Start of export
End of export
Unknown class found while creating script.
Irgendetwas mache ich falsch.
Vielleicht wäre es hilfreich eine Step by Step Anleitung zu machen,mit ein paar Fahrzeugen und Soldaten oder so,damit man das Prinzip dieses Programms versteht.
m.f.G.
06.06.08 um 08:19 Uhr

i0n0s


Registriert: 06.06.2008
Kommentare: 2

Zitieren eMail
Ich verlege das Ganze besser mal ins Forum: http://hx3.de/mod-addon-ecke-108/rte-feedback-fehlerreport-14810/
Da hat man doch mehr Möglichkeiten der Kommunikation ;)
29.05.09 um 13:36 Uhr

karl

Gast


Zitieren
Hallo,
Ich habe ein Problem mit dem Editor : ich kriege immer dieses Fehler :
"An error happened while injecting the DLL" wenn ich Rte_capture.exe aktivieren will.
Habt ihr eine Idee ?
Danke
Karl

Dein Kommentar